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1. Introduction 

1.1. What is VidaOne Diet & Fitness? 
VidaOne Diet & Fitness™ is the premier application designed to help you track and improve 
your health, fitness and nutrition. It can be used by anyone, from health-conscious people to top 
athletes, for a variety of reasons: 
 

 Follow a diet to lose or gain weight 
 Track all the food you consume along specific nutrients such as glucose, cholesterol, etc. 
 Keep a detailed log of all your activities including cardio-vascular workouts (walking, 

running, bicycling, swimming, etc) and strength-training (free weight, barbell, dumbbell, 
machine, ball, etc.) 

 Track your progress toward the completion of a workout goal 
 Enter health vital signs and other information such as body measurements and blood 

markers. 
 Print various reports to present to medical staff, doctors, etc. 
 Synchronize data with MySportTraining® and MyPersonalDiet® on mobile devices. 
 And more! 

 
VidaOne Diet & Fitness runs on Windows 7 (64- and 32-bit), Vista (64- and 32-bit) and XP. 

1.2. Using a Polar or Garmin Heart Rate Monitor 
VidaOne Diet & Fitness allows you to download workouts from most Polar® and Garmin® 
heart rate monitors, and to visualize key information about your training. It also makes it much 
faster to enter workouts, as most of the information is automatically entered for you. The models 
currently supported are the following: 
 
Polar (http://www.polarusa.com) 
 

 AXN500, AXN700 
 F6, F11, F55 
 CS200, CS300, CS400, CS600, CS600X 
 RS200, RS400, RS800, RS800CX 
 S410, S510, S520, S610, S610i, S625X, S710, S710i, S720i, S725, S725X, S810, S810i 

 
Garmin (http://www.garmin.com) 
 

 Edge 205, 305 (via USB cable) 
 Forerunner 205, 301, 305 (via USB cable) 
 Most other Garmin devices (via TCX files) 

 
Section 8 explains how to download workouts from those great monitors. 
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1.3. Using a Mobile Device? 
VidaOne Diet & Fitness synchronizes with MySportTraining® and MyPersonalDiet® for the 
following mobile devices:   
 

 Android phones running Android OS 1.6 and newer. 
 Blackberry phones running BlackBerry OS 5 or newer. 
 iPhone 2G/3G/3Gs, iPod Touch and iPad running iOS 3 or newer. 
 Windows Mobile Pocket PC (touch screen) running Windows Mobile 5 or newer. 
 Windows Mobile Smartphone (non-touch screen) running Windows Mobile 5 or newer. 
 Palm OS version 5 or newer 

 

 
 
MyPersonalDiet provides most of the diet and food tracking from VidaOne Diet & Fitness, 
whereas MySportTraining contains most of the fitness features found in VidaOne Diet & 
Fitness. Both applications are integrated and they share data on your device (except on the 
iPhone1). This makes it ideal to track your food and workouts on-the-go. Seamless 
synchronization then brings all the data to your PC  (desktop or laptop) into VidaOne Diet 
&Fitness. You can find more about these great applications at http://www.VidaOne.com. 
 
For Android, BlackBerry, iPhone, iPod Touch and iPad, the synchronization is done via Wi-Fi, 
so a wireless router is needed.  
 
For Windows Mobile Pocket PC, the synchronization is achieved via Windows Mobile Device 
Center (on Windows 7 and Vista) and ActiveSync (on Windows XP).  
 
For Palm OS handheld, the synchronization is implemented as a HotSync conduit. 
  

                                                 
1 Applications cannot share data on an iPhone as they are isolated from one another. 
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1.4. Mac OS X 
Although VidaOne Diet & Fitness is only available for Windows 7, Vista and XP, it can be run 
in emulation in Mac OS X using Desktop Parallels® or VMware Fusion™. The synchronization 
with MySportTraining for iPhone (see section 10.4 for details) has successfully been tested under 
both environments. PDF documents that describe how to set-up each environment for the 
synchronization to work are available at www.vidaone.com/vodf_win.htm. 

1.5. Technical Support  
You can obtain more information about our products, updates, etc. by visiting our Frequently-
Asked Questions (FAQ) page at: http://www.vidaone.com/faqs.htm.  
 
If you have a question, or want to provide some feedback or just a comment, please send us an 
email at: support@Vidaone.com. 
 
Or from VidaOne Diet & Fitness, click on the VidaOne icon in the application’s top left corner, 
then click About to show the About window, and click on Technical  Support at the bottom. 
 
You can also contact us by mail at the following address: 
 

VidaOne, Inc. 
5900 Southwest Pkwy 
Bldg 2, Suite 210 
Austin, TX 78735 
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2. Installation 
VidaOne Diet & Fitness is a self-contained application that comes with a standard Windows 
installation file. You do not need any special permission to install the software, unless you want 
to install it for all users, or need to synchronize with a Windows Mobile Device, in which case 
the installation should be done from a Windows account with administrator privilege (see section 
2.5 for details). 

2.1. First-Time Installation 
 Download the file http://www.vidaone.com/download/VODF_Setup.zip and save it on 

your computer. 
 Open Windows Explorer (the file browser), navigate to the directory where you saved the 

file and unzip the file as follows: 
o On Windows XP, right-click the file in and choose Open with > Compressed 

(zipped) folder. 
o On Windows 7 and Vista, select the file in the File Explorer’s left pane (which 

lists directories and zip files), and the file content will be displayed on the right 
side. 

 Double-click on VODF_Setup.msi and follow the on-screen instructions 

2.2. Un-installation 
Note that un-installing the software does not remove data. If you with to erase all your data, 
proceed as follows: 
 

 Open Windows Explorer (the file browser), go to the directory where VidaOne Diet & 
Fitness is installed (usually C:\Program Files\VidaOne\VODF), and double-click on the 
file vodfcln.exe. when prompt to remove all the data, click Yes. 

 
To uninstall: 

 On Windows XP, click Start > Settings > Control Panel > Add or Remove Programs, 
select the VidaOne Diet & Fitness entry, then click Remove. 

 On Windows 7 and Vista, click Start > Control Panel > Programs and Features, select the 
VidaOne Diet & Fitness entry, then click Uninstall. 

 

2.3. Re-installation of the Same Version 
To re-install the same version, you must first uninstall the current version (Windows does not 
allow re-installing the same version twice): 
 

 Make a backup via the Home toolbar > Backup. This is highly recommended, although 
uninstalling the software will not remove any data. 

 Uninstall the software as described above. 
 Install the software as described above. 
 Open the software and you will see all your data. 
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2.4. Upgrading to a Newer Version 
A newer version can be easily installed over the current version you have. You do not need to 
uninstall the version you already have. 
 

 Make a backup via the Home toolbar > Backup. This is highly recommended, although 
upgrading the software will not remove any data. 

 Simply download and install the new version, as described above (section 0). 

2.5. Installing with Administrator Rights on Windows 7 and Vista 
In some cases, to ensure that the software is correctly installed, right-click on VODF_Setup.msi, 
and select “Run as Administrator”. If that entry cannot be selected or is not listed, proceed as 
follows: 
 

 Click Start > All Programs > Accessories 
 Right-click the “Command Prompt” and select run as administrator (Figure 1). A User 

Account Control window prompting you to allow the program to run may show up, in 
which case click Yes. This open a Command Prompt window. 

 Enter the command “CD” followed by the directory where the file VODF_Setup.msi 
resides e.g. “CD C:\download”. Type <Enter> 

 Then type “VODF_Setup.msi” and <Enter>. This will install the software with 
administrator rights. 

 To close the Command Prompt window, type “exit” <Enter> 
 

 
Figure 1: Running a Command Prompt window in administrator mode. 
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3. Quick Tour 
The VidaOne Diet & Fitness main screen is shown in Figure 2.  
 

 
Figure 2: VidaOne Diet & Fitness main screen under Windows XP. 

 
The application Ribbon is designed to make the features of the application more discoverable 
and accessible with fewer mouse clicks as compared to the menu-based UI used prior to this 
version. There are four categories (Home, Diet, Fitness and Profile) that provide all the features. 
 
The Quick Toolbar area (in the title bar) can be customized to add your preferred commands 
already in the ribbon. You can also choose to auto-hide the Ribbon to make more room for the 
current view area. Some screenshots in this document were taken with the Ribbon hidden. 
  
The main area underneath the Ribbon is the current view area. Views are explained in details in 
the following pages. To the left, the Current view’s options allow you to customize each view. 
 
The view navigation area (bottom left) allows you to quickly jump from one view to another.  
  
To exit VidaOne Diet & Fitness, select Exit from the VidaOne Button. 

Application Ribbon 

Current view’s 
options 

View 
navigation 

area 

 
 
 
 
 

Current view area 

Quick Toolbar (fully configurable)

VidaOne 
Button 
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4. Profiles 

4.1. What Is a Profile? 
VidaOne Diet & Fitness is designed to store diet, food workout, health records and personal 
settings for multiple users. Each user is assigned a profile, and as many profiles as you want can 
be created. For instance, if John and Mary are going to use VidaOne Diet & Fitness, each should 
create his or her own profile, respectively called “John” and “Mary”, and select it when using 
VidaOne Diet & Fitness. Using his profile, John will only see his workout; using her profile, 
Mary will only see hers. Passwords can be assigned to each user to make sure that any user only 
has access to his or her data only. See section 4.3 for more information about confidentiality. 
 
Only one profile is active at any moment, and the current profile is shown in the title bar next to 
“VidaOne Diet & Fitness”. For instance, in Figure 2, the title bar indicates that the profile for 
“John” is the current. 

4.2. Creating Profiles 
The Welcome wizard, shown upon starting VidaOne Diet & Fitness for the first time, will 
prompt you for a profile name, among other information. Even if you will be the sole user of 
VidaOne Diet & Fitness, a profile is required. It is best to enter your first name, but you can enter 
any name you want. The profile remains active until you select another profile (described 
below). You can create additional profiles (one for each member of your family, for instance) by 
clicking Home > Add > Profile (see Figure 3). Simply enter the name of the new profile and 
click OK. This will create the profile and make it current. 
 

  
Figure 3: Creating a profile. 

Make sure this button is 
selected in order to add a 
profile. 
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To select another profile, click Profile > Select. This will show the Select window (see Figure 
4). Simply select the profile to open and click OK to make this profile the current.  
 

  
Figure 4: The Open Profile window, which allows you to select  

another profile and make it current. 

You can edit or remove an existing profile. Note that since VidaOne Diet & Fitness requires at 
least one profile, it is not possible to delete a profile unless there is another one to use. 

4.3. Profiles Confidentiality and Security 
Profiles data can be kept confidential by requiring each user to enter a password when opening 
their profile. To enable security, click Profile > Passwords and select the Enable security 
checkbox. Upon enabling security, you will be prompted for a password to secure your data. 
Your profile automatically becomes the Administrator profile, giving your profile (and your 
profile only) the right to perform the following actions: 
 

 Disable security 
 Create, edit or delete profiles 

 
Note 

 
Make sure to write down your password. If it is lost, you will not be able to access 
your data nor perform the actions listed above. 

 
Once the security is enabled, the other users will be prompted to enter a password when opening 
their profile, as shown in Figure 5. 
 
Passwords can be changed in the Open Profile window. When security is enabled, a password 

button  is shown and allows the password to be changed for the selected profile. 
 

Click this button to edit 
the name. You can also 
click once on the name to 
edit it. 

Click this button to 
remove the profile. 

The PDA symbol 
represents the user whose 
data is synchronized 
with. See page 83 for 
more details. 
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To disable security, open the Administrator profile,  click Profile > Passwords and clear the 
Enable security checkbox. 
 

 
Figure 5: When security is enabled, users must enter a password to access their data.  

This ensures that user’s workout and health data remain confidential. 

 
There are a few topics to take into account when enabling security: 
 

 Only the user who enabled the security can later on disable it. Under any other profile, 
the checkbox Enable Security in the Security is disabled (grayed). This ensures that 
none can disable security but the user who enabled it. 

 
 After turning on security, it is recommended to open each existing profile immediately in 

order to assign passwords (because once security is enabled, opening a profile the first 
time requires entering the password). This ensures that each user’s data is protected. 

 
 Upon opening VidaOne Diet & Fitness, the Profiles window is shown and the user must 

select a profile (and enter a password) as shown in section 2. Without security, the last 
profile used is immediately opened. 

 
 Upon launching VidaOne Diet & Fitness, if it is detected that the security has been 

tampered with, the user who enabled the security will be required to enter his/her 
password, and then security will be disabled (since passwords might have been modified 
and/or removed). Security must be turned on again and passwords must be entered for all 
existing profiles (as described above). 

 
 It is crucial the administrator password is not lost, because VidaOne Technical 

Support cannot recover it. 
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5. Views 

5.1. The Summary View 
The Summary view (see Figure 6) presents an overview of your diet/weight, calories, food and 
workouts. It consists of multiple charts which you can configure. You can choose the number of 
charts to display (from 1 to 6) using the Layout button  and you can select which chart to 
display using the Select button . You can also select the period to display the data from. 

 

 
Figure 6: The Summary view shows an overview of your body weight  

(or diet), and workouts for a given period.  

  

Click here to 
change the period. 

Click here to see 
a different chart.

Click here to choose 
another picture. 

Select how many 
charts to display. 
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5.2. The Journal View 
The journal view shows the meals, workouts and health information for a given day. It also 
presents a daily summary (at the bottom on Figure 7) consisting of four different charts: 
 

 Energy balance, showing the amount of energy consumed (by meals) and spent (via the 
BMR and workouts). 

 Energy breakdown, showing a pie that presents where the energy came from among 
carbohydrates, proteins and fat. 

 Nutrients tracking, which allows you to select any nutrient and see how much you 
consumed. If you set min/max limits (see section 6.2), they will also be shown. 

 A summary list of the nutrients consumed for the day. 
 

 
Figure 7: The Journal view shows meals, workouts and health information for the day. 

 

Select here what 
panels to show. 

Various daily charts are available. 

Days in bold 
indicate days 
with data. 

Click here to go to the previous, 
next or current day. 

Double-click on an 
item to edit it. 
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5.3. The Calendar View 
The Calendar view shows a monthly summary of your meals, workouts and health for a given 
month. You can customize the appearance and easily navigate from one month to another. You 
can also print it. You can double-click on any day to open in the Journal view. 

  

 
Figure 8: The Calendar view shows a monthly summary of your meals, workouts and health. 

 

 

Click here to go to the previous, 
next or current month. 

Click here to select 
a specific month. 

You can customize the 
appearance of the calendar. 

Weekly workout 
summary. 

Click on any day 
to open it in the 
Journal. 

This symbol indicates that there 
are more workouts on this day 
which are not shown (because 
there’s not enough space to 
display them all). 
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5.4. The Report View 
The Report view allows you to see a variety of reports about your meals, workouts and health. 
All reports can be printed. 
 

 
Figure 9: The Report view allows you to select all sorts of reports, which can be printed. 

 
Only workouts done during the period are listed. As a result, depending on the period, you may 
not see the same activities listed. 
 
The Current Reports section (near the top left corner) shows the reports that currently opened. 
Click on an entry to see the associated report. Right-click on the entry and choose Remove to 
remove the report from the list. 

You can select meals, 
workouts and health reports 
by clicking on an entry and 
choosing “Open”, or by 
double-clicking on it. 

Easily access 
reports you 
previously 
opened. 

Select 
reports of 
interest. 

Click here to select 
another period. 
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As an example, here is the “All Meals” report, which details all the food you consumed. 
 

 
Figure 10: The “All Meals” report. 

 
And here is a workout report (Road Cycling in this case).  
 

 
Figure 11: A workout report. 

 

Right-click an entry to edit, 
cut, copy, paste or delete the 
workout. 
 
Double-click on it to edit 
the related workout. 
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5.5. The Graph View 
The Graph view allows you to visualize information about meals, nutrients, workouts, health, 
body measurements, blood markers and body measurements. Graphs can be printed and 
customized (see section 10 for more details). 
 

 
Figure 12: The Graph view allows you to visualize all the information you’ve entered. 

Easily access graphs you 
previously opened. 
 
Also right-click on an entry 
to remove it from the list. 

You can 
select 
categories 
of graphs 
to show. 

You can select meals, 
workouts and health reports 
by clicking on an entry and 
choosing “Open”, or by 
double-clicking on it. 
 
You can also click “Filter 
and Open” to enter specific 
criteria about the 
information to graph. 



VidaOne Diet & Fitness for Windows 7, Vista and XP User’s Guide 19 

The Current Graphs section (near the top left corner) shows the charts currently opened. Click on 
an entry to see the associated report. Right-click on an entry and click Remove to remove it. 
 
You can apply a filter in order to display workout that meet specific criteria, by clicking Filter 
and Open. This will show the Advanced Workout Filter (see Figure 13), which allows you to 
enter up to three conditions. 
 

 
Figure 13: The Advanced Workout Filter allows you to select only the workouts that meet specific conditions. 

 
There are over 30 graphs about meals, nutrients, workouts, health, body measurements, markers 
and the custom fields you created. Here are a few samples: 
 

 
 

Meals 
 
The Calorie Intake and  Expenditure represents the 
calories (or kJ) consumed (meals) vs spent (BMR + 
workouts) 
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Workouts 
 
The duration graph represents the time spent 
exercising. 

 
 

Nutrients 
 
The Total Carbs graph shows the consumption of total 
carbohydrates. 

 
 

Health 
 
The Blood Pressure shown over time. 

Health 
 
The Body Mass Index (BMI) gives you a good 
indication of your weight classification. 
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Body Measurements 
 
The Biceps graph shown over time. 

Custom Fields 
 
You can also visualize all the custom fields you’ve 
entered. 

 
By default, the Pace graph uses the pace units as they were specified in the workouts. When 
opening the Pace graph, you will be prompted for the unit to use (see Figure 14).  
 

    
Figure 14: The Pace chart can be customized by activity and pace unit.  
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6. Diet 

6.1. Starting a Diet 
The first time you run VidaOne Diet & Fitness, the welcome wizard helps you set your goals, as 
described below. If you want to later review or change your goals, select Diet > Goals and 
choose “I want to follow a diet and enter my goals”.  

Entering your Profile 
Your profile is required in order to perform various calculations within MyPersonalDiet. It is 
important to enter all values to obtain the best results. The profile consists of the following and 
you can later change your profile if required by clicking Profile > My Profile: 
 

 Gender 
 Birth year 
 Height 
 Activity level 

Weight Goal 
Based on your profile, VidaOne Diet & Fitness calculates your Body Mass Index (BMI) and 
presents you with a chart showing your weight vs. various weight ranges (see Figure 15). You 
can then quickly find out and enter your target weight and as a result, set a realistic weight goal. 
 

 
Figure 15: Based on your profile, VidaOne Diet & Fitness helps you identifying your target weight. 
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Duration 
Once your profile and target weight are known, you have to choose how long your diet will take. 
VidaOne Diet & Fitness presents you a period in which you can reach your target weight 
following a healthy diet (see Figure 16). It is very important to choose a realistic duration (within 
the proposed range). Not doing so can hurt your health. For instance, it is possible to lose weight 
faster than the period shown, but this results in muscle mass losses, and other harmful effects. 
 

 
Figure 16: MyPersonalDiet presents you a period by which you  

can reach your target weight in a healthy manner. 

Diet Summary 
With your profile, target weight and diet duration entered, VidaOne Diet & Fitness summarizes 
your diet and shows you how many calories (or kilojoules) you need to lose (or gain) every day 
in order to reach your target weight. This gives you a solid daily guideline to establish your food 
and exercises habits.  
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6.2. Choosing a Diet 
Before entering data, you can choose the diet you want to follow and identify nutrients to track 
and the daily energy. Click Diet > Diet Plan to show the Diet Plan window, which includes 
Plan, Nutrients, Energy and Schedule tabs. 

Diet Plan 
The Plan page allows you to select one of the following predefined diets: 
 

 USDA Food Pyramid 
 High Carb 
 Low Carb 
 High Protein 
 Low Protein 
 Low Fat 

 

 
Figure 17: You can select various diet plan or create your own 

As you select them, the energetic percentage from the major nutrients (carbohydrates, proteins 
and fat) are displayed (see Figure 17). 
 
In addition, you can choose Custom Plan and select the exact proportion of energy from these 
nutrients. 
 
Later on, as you enter food, you will be warned when food do not match these requirements (see 
section 7.1 for more details). This allows you to avoid food that may not be a good fit for your 
diet.  
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Nutrients 
You can track specific nutrients to make sure that you consume enough of them and/or do not 
consume too much of them. This is of prime important for those who have a medical condition 
that imposes some restrictions on specific nutrients. 
 

  
Figure 18: You can set minimum and maximum limits on any nutrients.  

Those limits will be used in different views, reports and graphs. 

The Nutrients page shows you a list of nutrients for which you can optionally assign a daily 
minimum and/or maximum limits. For instance, if you need to follow a diet that does not exceed 
300 mg of cholesterol per day, enter 300 under Maximum next to Cholesterol. If you need to 
consume at least 1000 mg of calcium daily, then enter 1000 under Minimum, next to Calcium. 
 
You can later chart these nutrients in the Daily and Chart views respectively for more 
information) to see where you stand with regards to the limits you chose. For instance, from the 
Day view, you can see a chart of your daily sodium consumption and be informed whether you 
can consume more of it for the day (and how much) or if you’ve exceeded the limit (and by how 
much). 
 
This gives you the ability to precisely control your diet and make sure you are following your 
own guidelines. 
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Energy 
You can set a limit of the energy you want to consume daily (e.g. 2000 calories). This is used 
when calculating the daily dietary intake (%DV). 
 

 
Figure 19: You can specify how many calories you normally consume to  

help calculate the daily dietary intake (%DV). 

Meal Schedule 
You can enter your meal schedule i.e. the time of day and the amount of energy for each meal 
you consume on a daily basis (see Figure 20). Based on that schedule, VidaOne Diet & Fitness 
can determine the meal type of each meal as you enter it, and you can later see using the Meal 
Schedule graph whether you follow this schedule or not, and how much energy you consume on 
average per meal. 
 
This is very useful in two situations: 
 

1) If you are on a weight loss diet, two common problems are eating between meals, 
and to consuming too much food at night. The Meal Schedule chart will immediately 
let you find out if you are eating outside your planned meal schedule and too much at 
certain meals. 

 
2) If you are an athlete or someone with food restrictions, and you consume several 

meals a day (4 or more), the meal schedule and the Meal Schedule graph will greatly 
help you making sure that you are eating enough at each meal (as opposed to eating 
too much in some meals and not enough in others). 
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Figure 20: You can specify how many calories you normally consume to  

help calculate the daily dietary intake (%DV). 

6.3. Diet Results 
During a diet, click Diet > Results to see an overview of your diet along the following aspects: 
 

1. As of Today shows where your weight is vs. your goal. You will immediately know if 
your weight is where it should be or not. 

 
2. About Eating shows how many calories (or kilojoules) you need to lose (or gain) to 

reach you goal, and how much on average you lost (or gained) since the start of your diet. 
 

3. About Exercising calculates how often you exercise and for how long, and lets you 
know if that’s enough or not.  

 
4. What To Do shows recommendations to reach your goals, based on your actual weight 

and your eating and exercising habits, such as “consider eating less, or “consider eating 
more”, etc.  

 
Note: these recommendations are only that: recommendations. Use your own judgment to 

determine if they are suitable for your condition or not. You may also want to seek the help of a 
health professional to help your reach your goals. 
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6.4. Food Organizer 
The Food Organizer (Diet > Food Organizer) allows you to customize the food database: 
 

  
Figure 21: The Food Organizer allows you to customize the food database. 

 
You can create food items by clicking on New Food. You can copy an existing item (to 
customize it) by clicking on Copy Food. 
 
The customization performed on the food database is entirely synchronized with your Pocket PC 
if you are using MyPersonalDiet for Pocket PC. Food items created on MyPersonalDiet for 
Pocket PC are also synchronized and available on your PC. 

Filtering Food Items 
The food database contains thousands of food items, many of which you may never consume. 
Simply select the categories and food items that interest you, leaving the others unselected. 

Exporting and Importing Food Items 
You export the categories you created under My Food. Simply select a custom category, click 
Export, select a file name (with the VDX file extension) and click OK. To import food items 
(e.g. from your friend), click Import, select a VDX file, and the food items will be stored under 
My Food. 
 

You can 
unselect food 
items and 
categories you 
never consume 
to hide them. 

You can export custom food 
categories (under “My Food”). 

You can import  custom food 
under “My Food”. 
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7. Entering Meals, Workout and Health Records 
Meals, workouts and health records can be entered from different locations: 
 

 Choose Home > Add, then select among “A Meal”, “A workout” or “A daily health 
record”. 

 Choose Home > Meal, Home > Workout, or Home > Health Record. 
 From the Journal view, by double-clicking in a blank area in the Meals, Workouts or 

Health panels. 

7.1. Entering Meals 
The Meal window is shown in Figure 22. 
 

   
Figure 22: The Meal window allows you to enter food items and extra servings for a meal. 

Use this button 
to clear  all 
listed entries. 

You can enter a 
note about the 
meal. 

Enter extra 
servings here. 

Quickly search 
the database. 

Enter custom 
fields here. 
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Entering Food Items 
You can add, edit or delete food items from the meal using the Add, Edit and Delete buttons 
respectively (more on this later). 
 
You can also tap the down arrow  next to the Add button to add one serving of the following: 
 

1. A food item from your favorite food item list 
 

2. A food item you search for. 
 
Depending on the time of the day and the meal schedule (see Meal Schedule in section 6.2), a 
type of meal will automatically be selected. You can change it if needed. 
 
You will later see how food items can be combined into dishes. The Dish list is initially empty 
the first time you use VidaOne Diet & Fitness, but once dishes are created, you can select them 
using the Dishes button and their food items will be added to the list. 
 
When you choose Add from the Meal window, the Food Browser is shown (see Figure 23). This 
is the main window by which you enter the food you consume. 
 
To enter a food item, select a food group and a category and then choose a food item. Upon  
choosing an item, the Food Information section (the lower part of the screen) will be updated 
with useful information. You can use this information to find out exactly what you are 
consuming. Go ahead, and browse the whole database to learn about what you are really eating! 
You’ll be surprised! Click the Nutrition Facts button  to see more information about the food 
item (see Figure 24). 
 
Then choose the amount (or quantity) you consumed. The calories (or kilojoules) field, along the 
nutrients data, are updated to reflect the amount you are consuming. This information allows you 
to precisely decide whether you should eat the whole portion you had in mind (or perhaps only 
half of it). 
 
Once done, tap the Add to Meal button to add the food in the meal.  
 
Food items that you add are also stored in the Favorites list (more about this shortly). 
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Figure 23: The Food Browser window allows you to browse the entire food database and  

enter the amount you consumed of the selected food item. 

 

 
Figure 24: You can see nutritional facts for each item in the food database. 

Messages like this 
are shown for 
food items that do 
not match your 
diet plan. In this 
example, this 
food is not 
appropriate for a 
“low carb” diet.

See nutrients by 
weight or %DV 

Drag the corner 
of the window 
to resize it. 

Right-click on 
custom 
categories to 
edit or delete 
them. 

Right-click on 
custom food 
items to edit or 
delete them. 
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Favorite Food Items 
Whenever you add a food item into a meal, that food item it added to the favorites list. The 
favorites food item list is accessible by tapping the Favorites button  in the Food Browser. 
This shows the most recent favorite food items; tap on one to select it. Using the Favorites button 
is a quick way for selecting food items you frequently consume. 
 
The list items contains a limit of items that can be added. The purpose of this limit is to discard 
food items you rarely consume. You can “pin” an item (tap-and-hold the item and select Pin to 
make sure the item is not automatically removed from the list as new items are added. To 
“unpin” an item, tap-and-hold the pinned item and select Unpin. 
 
When you select a food item, it is added to the meal using an amount of “1 serving”. If you 
prefer to be prompted every time you select the item, tap-and-hold the item and uncheck Use 1 
serving. 
 

   
Figure 25:The Favorite Food Items window lists all your favorite food, grouped by categories. 

Click this button 
to control how 
many items can 
be held in the list. 

Right-click an 
item to remove it 
from the list. 

Drag the corner 
of the window 
to resize it. 
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Searching Food Items 
You can search the food database by tapping the Search button . This shows the Search 
window (see Figure 26). Enter a word (or part of a word) and tap Search to show the matching 
food items from the food database and from your own food. 
 

 
Figure 26:The Search Food window allows you to search the food database for a specific keyword. 

 
Searching by one word can return too many items (159 in the previous example) To perform a 
more effective search, enter several words, and only items containing all words will be shown. 
What’s more, prefix a word with an hyphen (–) to exclude food items that contain that word.  In 
Figure 27, the search returned entries that contains both milk and lowfat, but not cheese (bringing 
the number of entries down to a more manageable 5). 
 

Drag the corner 
of the window 
to resize it. 
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Figure 27:An enhanced search returns fewer and more accurate results. 
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Combining Food Items Into Dishes 
You can save one or more food items as a dish, and use that dish later on to expedite data entry. 
Figure 22 shows the New Meal window with a few food items. Click the Dishes button, select 
New Dish and enter the meal’s name, serving size and the amount of servings it contains (see 
Figure 28), in order to save the food items under that meal.  
 

 
Figure 28: When creating a dish, you can also choose to add one serving when recalling that dish  

(or instead being prompted for the amount to use). 

 
To use that meal at some other time, select its name from the meal list, click on the Dishes 
button and select Add Dish. A single serving of that dish will be added, unless the option 
“always use 1 serving when adding this dish” was selected when adding/editing that meal; in that 
case, you will be prompted for the exact amount to use. 
 
You can update the content of a meal with the food items currently listed. Simply click on the 
Dishes button  and select Update Dish. If you want to delete the dish, choosing Delete Dish 
instead. Deleting a dish does not remove the food items currently listed. To rename the dish, 
choose Edit Dish. 

Enter Your Own Food Items 
You can add your own food items by clicking on New Food button in the Food Browser. This 
shows the Custom Food Item window (Figure 29). Enter the name, the default serving (e.g. 100 
g, 1 cup, etc.), the calories (or kJ) for that serving, the food group this food item belongs, the 
nutrients and a note if desired.  
 
Choose the Calculator  button to calculate the energy based on the nutrients you’ve entered. 
The calculation is based on 4 calories per gram of Total Carbs and Protein, and 9 calories per 
gram of Total Fat. 
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Figure 29:The New Food Item window allows you to enter you own food items. 

Enter Additional Servings 
When entering a meal (see Figure 22), you can enter additional information for the meal. 
 

 Amount of water servings you consumed (one serving is 1 cup or 250 ml), a quicker 
alternative to enter water via the Food Browser. 
 

 Extra calories (or kJ) for the meal. If all you want is to track is the energetic value of 
a meal and you know what it is, you can simply enter it there, without providing 
additional information. Note that the nutrients will remain zero for this meal. 

 
 Additional servings for the meal. This is useful when you eat a meal composed of a 

variety of food items: instead of entering each of them individually, you can estimate 
how many servings of each food group the meal is composed of, and only enter the 
servings. MyPersonalDiet uses average energetic values per food group serving, as 
displayed in following table (values are rounded for simplicity) 

 
Food group Total cal. Cal. from carbs Cal. from prot. Cal from fats 
Starch (grains) 90 68 8 14 
Protein 179 29 56 94 
Fruit 98 90 3 5 
Vegetables 69 52 8 9 
Dairy 102 16 27 59 
Fats, oils, etc. 108 31 4 73 

Table 1: Energetic values per food group (per serving). 

You can choose to enter the 
nutrients by weight (g or mg), or 
by percent daily value (%DV). 

Tap this button to calculate the 
calories based on the carbs, 
protein and fat nutrients. 

Nutrients are listed 
in the same order 
than you find on 
US food labels. 
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7.2. Entering Workouts 
If you are using a Garmin or Polar heart rate monitor, refer to section 8 on page 56. 

Adding a Workout 
To add a workout, click Home > Workout. The Add window (see Figure 30) is shown: 
 

 Select A workout. Check Apply activity filter to display only the activities you have 
filtered (see section 9.2 for information on filtering activities). 
 

 Choose an activity among those listed. You can add an activity by clicking the Add 
button. See the Entering Strength Training section on page 46 for more details.  

 
 You can also edit or delete activities you previously created. Delete a custom activity will 

not remove the workouts you entered for that activity. 
 

 Click OK 
 
Next, a workout data entry window is shown for the selected activity. There are two types of 
workout data entry windows: cardio (Figure 31) and strength (Figure 32). There are only a few 
differences, which are described in the following sections. 
 

  
Figure 30: Adding a workout. 

 

You can add, edit or delete a 
custom activity by clicking 
this button.

Activities you recently chose 
are shown first (using a pale 
blue background). 

Check this box  to display 
only the activities of interest 
to you. See section 9.2 for 
details of the activity filter. 
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Figure 31: The workout data entry windows for cardio workouts. 
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Figure 32: The workout data entry windows for strength workouts. 
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You can enter as much information as you want (the more the better), but you can leave any field 
blank as well. 
 

General information: 
 

 Date and time 
 

 Enter the workout duration. Format is either hour/minute/second or hour/minute, 
depending on the workout duration setting (see section 10.10 for details). Note that the 
Calories and Fat fields are automatically updated based on the duration you enter 
and your weight. You can change those values by clicking on them; you will be 
prompted for a new value. Should you modify them, they will no longer be updated when 
the duration or exertion is changed, unless you reset them to 0. 

 
 Enter your perceived energy, exertion, your overall rating of your workout, and a note 

about this workout (weather, etc.) Note that changing the perceived exertion may 
change the Calories and Fat fields, as it does for the duration. 

 
For cardio workouts only: 
 
 Enter the location information:  course, distance, pace and ascent (elevation). To browse, 

add, or delete courses, click the  button (see section 7.4 regarding browsing). Note 
that upon choosing a course, the distance and pace will reflect the course’s default 
distance and pace. 
 

 If the record was recorded using VidaOne GPS on your mobile device and later 
synchronized, you can view the course by clicking on the GPS          button. You can 
choose to see the route as follows: 
 

o Using VidaOne GPS route viewer. 
o Using Google Maps (requires an active Internet connection) 

 
If the workout does not have a route associated with it, you can import a GPB files. GPB 
files are generated by VidaOne GPS. 

 
 Enter weather information 

 
For strength training workouts only: 

 
 Enter the location at which the training took place. To browse, add, or delete locations, 

click the  button (see section 7.4 for information regarding browsing). 
 

 Enter the warm-up and cool-down period. 
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Detailed information: 
 
 Enter the average training heart rate, the target zone, and the percentage of time spent in 

the target zone.  
 

 Click the Training Zones button to edit your training zones (more in section 9.4) 
 

 Click the Calculator button to calculate the percentage (see Figure 33). 
 

 
Figure 33: The Percentage Calculator window. 

 
 You can track up to four gears (e.g. running shoes, bicycles, heart rate monitor etc.) that 

you used for the workout. Refer to section 9.4 for more details about gears. 
 

 Enter up to four custom fields (see details in the next section). 
 

Detailed information for cardio workouts only: 
 

 Enter lap or interval training data (see the Entering Cardio Training Intervals section 
below for more information about intervals). 

 
Detailed information for strength workouts only: 

 
 Enter the exercise data (see the Entering Strength Training Exercises section on page 46 

for more information about exercises). 

Tracking Your Own Data with Custom Fields 
One of the most powerful features of VidaOne Diet & Fitness is its ability to track the data of 
your choice for activity and health records. This is very useful for entering specific information 
about your workouts or your health that is not listed by default. Here are a few examples: 
 

 Any special equipment you use, or the videotape you watched while exercising. 
 In a competition, your position/rank in the final classification. 
 Any food supplement you took prior to, during, or following the workout. 
 Health information such as glucose or cholesterol, for example. 
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All in all, you can enter any information you want to track, whether it is a number or a value 
from a selection list (that you define!) In addition, each custom field is listed in the Graph view, 
so that you can see a chart of the values you entered. 
 

To add a custom field, click the Browse Custom Field  button next to the <…> fields, 
from either a workout window (Figure 31) or the Health window (Figure 41), and choose Add 
Field. The Add Custom Field window (Figure 34) will be displayed, and will allow you to enter 
the following information: 
 

 The name of the field (which you can change later). 
 
 The type of value to track, either a number or a selection. 

 
o Number: you can enter a positive number (e.g. 1, 1.5, 1.52, etc.) Check Do not 

display if 0 if a value of 0 should not appear in a graph. 
 

o Selection: use the buttons next to the list to add values from which to choose. You 
can revisit this list at a later time and add other values. However, the order is very 
important and it is not recommended that you remove values already listed, even 
if you don’t plan to use them anymore. 
 

Note 
 

Once the list is defined, do not delete or alter the order of the values already 
entered. Otherwise, the values entered in previous workouts may be displayed 
incorrectly. 

 
 Since the custom field will be included in the graph view, enter the type of graph to show 

and the color to use. You can see a sample of the graph as you set these parameters.  
 
Once a custom field has been added, it will be added to the menu displayed after clicking the 
Browse Custom Field button, as shown below: 
 

 
 

The list of available custom 
fields you have previously 
created is automatically 
shown. Click on any field to 
select it. 

This selection allows you to 
‘erase’ the custom field 
being used in the workout or 
health record. 

You can add a custom field 
as well as edit or delete the 
current custom field by 
using these options. 
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When entering a workout (or health record), simply select a listed custom field in order to use it, 
and enter the appropriate value. If the custom field is a number, simply enter the appropriate 
value; if the custom field is a selection field, simply choose the appropriate value from the list. 
 
To clear the custom field, select Clear Field. For instance, if you chose the Bike custom field 
and decide that you don’t want to enter a Bike value, you may choose not to enter any value, or 
you may click Clear Field to unselect the custom field altogether. 
 
You can later edit a custom field by choosing Edit from the menu. You can also remove a 
custom field by choosing Delete. Note that this removes the custom field definition. As a result, 
it can no longer be selected in workouts or health records. 
 

  
Figure 34: The Custom Field window. 

This shows an example 
of what the graph will 
look like based on the 
graph type and color 
you choose. 
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Creating Your Own Activities 
VidaOne Diet & Fitness comes with pre-defined activities, such as Road Cycling, Running, etc. 
You can easily add unlisted activities, or even create specialized activities, such as ‘Time Trial’ 
(a specific road cycling type of training). To add an activity, click the Add button (refer to 
Figure 30) to add an activity. The New/Edit Activity window will be shown (Figure 35): 
 

 Enter the name of the activity. 
 

 Choose the type of activity (either cardio-vascular or strength). 
 

 Choose an icon by clicking one of the displayed icons. You can change the color of the 
icon by clicking the “Color” button. 
 

 Choose how to calculate calorie expenditure (i.e., the amount of calories you burn while 
performing this activity): 
 

o Choose Use default calculation to approximate the calorie expenditure based on 
your gender, the type of activity (cardio or strength), the duration, and the 
intensity of the workout. 
 

o If you know how many calories you burn for a given workout of that type (if you 
use a treadmill or other equipment that calculates the number of calories), simply 
enter how many calories you burn for a given period of time at a specific 
intensity. When you later create workouts for that activity, the calorie expenditure 
will be calculated by VidaOne Diet & Fitness using these parameters. 

 

  
Figure 35: The New Activity window. 

VidaOne Diet 
& Fitness can 
precisely 
calculate how 
many calories 
you burn for 
subsequent 
workouts if you 
enter these 
values. 
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Entering Cardio Training Intervals 
You can enter interval training data for your cardio workouts: 
 

 Select a cardio workout (see Figure 31). 
 
 In the interval list, choose Add. The interval data entry window will be shown (see Figure 

36). 
 

 
Figure 36: The Interval data entry window. 

 Select an interval. To update intervals, choose the Add, Edit or Delete buttons (see 
section 7.4 for information regarding browsing). 

 
 Enter the number of sets. 

 
 Enter the duration for each set, using the format shown next to the field name (the exact 

format depends on your regional settings). If the duration varies from one set to another, 
use the Notes field to enter more information if desired.  

 
 Enter the recovery period following each interval, using the format shown next to the 

field. If the recovery varies from one set to another, use the Notes field to enter more 
information if desired.  

 
 Enter the rate of perceived exertion (RPE) 

 
 Enter a note if desired. 

 
 Click OK to close the window.  
 

When adding a new cardio workout, an option allows you to carry over the previous interval data 
for the same activity (see section 10.10 for more details). 
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Entering Strength Training Exercises 
You can enter individual exercises for your strength workouts: 
 

 Select a strength workout.  
 

 In the exercise list, choose Add. The exercise data entry window will be shown (see 
Figure 37). 

 

  
Figure 37: The Exercise data entry window. Predefined exercises are shown with pictures. 

 
 Select an exercise. To update the exercise list, choose the Add, Edit or Delete button (see 

section 7.4 for more information about browsing exercises). Upon choosing an exercise, 
the Unit field will reflect the exercise’s default unit. 
 
You can also select an exercise by clicking on the Muscle Chart button, which shows the 
muscle chart (see Figure 38). Muscle groups are displayed using different colors. Simply 
move the mouse over a muscle group to see its name (which will be displayed in a small 
popup window). Right-click on a muscle group and a menu of related exercises will be 
displayed. Click on one of those exercises to select it. 
 
Exercises that you created will also be displayed provided you specified the muscle 
groups being worked on (see section 7.4 for details). 
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Figure 38: The Exercise data entry window. The muscle chart allows you to select exercises  

that are relevant to specific muscle groups. In this figure, the user right-clicked on the “Obliques” muscle 
group, which shows three (3) suitable exercises. 

 
 To see the most recent occurrences of the exercise, click on the Chart button. 

 
 Enter the number of sets. The number of sets is limited to five different sets, or up to 250 

identical sets. If you do more sets, add the exercise again in the exercise list. 
 

 Select Show each set if you want to enter the repetition and weight for each individual 
set. This is useful if, for instance, you use reduced sets, where the first set is a little lighter 
(to warm up) than the remaining sets. Don’t select this option if you use the same 
repetition and weight for each set. 

 
 Enter the number of repetitions and weight. If those numbers vary from one set to 

another, select Show each set as explained above. VidaOne Diet & Fitness internally 
records the maximum weight you enter for each workout. When you enter a new 
maximum, VidaOne Diet & Fitness will display a message stating that you did reach this 
new maximum. Once a maximum has been entered, an option called “Use % of max 
weight” will be displayed on the screen. You can then select it to enter the weight as a 
percentage of your recorded maximum. 

 
 Enter the unit. Remember to use the same unit when entering other instances of the 

exercise. If the weight varies from one set to another, use the Notes field to enter more 
information if desired.  
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 Click on the Duration field to select how long each rep takes, as one of the following 
values: 
 

o Duration in seconds of a single rep 
o Tempo phases i.e. eccentric and concentric, including isometric phases 
o Time-based, meaning that the set lasts a specific amount of time (e.g. 30 seconds) 

regardless of the number of reps. 
 

 You can select the equipment used for this exercise. 
 

 Enter the rest period. You can choose “None!” for supersets (i.e. when starting the next 
exercise without taking any rest after the current). Superset exercises will be displayed 
with the superset icon  in the exercise list (in the “rest” column”). 

 
 Choose the Rate of Perceived Exertion (RPE), which is based on the standard Borg CR10 

scale. 
 

 Enter an optional note if needed. 
 

 Choose OK to close the window.  
 
When adding a new strength workout, an option allows you to carry over a previous similar 
workout's exercises (see section 10.10 for information about workout options). 
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Editing a Workout  
To edit a workout, first display the related activity window (see section 4.3 for details about 
activity views). Then locate the workout, right-click on it and select Edit Workout, or simply 
double-click on the entry. Directly modify any values you want to change, as you would when 
entering workout data. 

Copying and Pasting a Workout  
You can cut or copy and paste any workout. For instance, you can copy a past workout in order 
to add a similar workout, or you can cut and paste a workout to move it from one date to another. 
 

 Select the workout in the Calendar. 
 Right-click the entry. A menu will appear, consisting of Cut, Copy, Paste, and Delete. 
 Choose Copy. A copy of the workout will be internally created. 
 Then right-click anywhere on the view to display the same menu again. 
 Choose Paste. This will show the Paste To window (see Figure 39). 
 Select a date and click OK. This creates a new workout based on the past workout (i.e., a 

copy). If you paste a workout not related to the activity being shown (for instance, 
pasting a running workout in the road cycling activity view), you will be prompted to 
open the appropriate view (the running activity view in this case). 

 

 
Figure 39: The Paste To window lets you choose a date to paste clipboard information to. 
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Deleting a Workout  
Deleting a workout permanently erases the workout data. 
 

 Select the workout. 
 
 Right-click the entry. A menu will appear, consisting of Cut, Copy, Paste, and Delete. 

 
 Click Delete. You will be prompted to confirm the deletion. 

 
 Click Yes to permanently delete the workout, or No to cancel and keep the workout.  

More About Intervals and Exercises 
Right-clicking an interval or exercise shows the following menu, and allows you to: 
 

 

 Edit the interval/exercise. You can also double-click the interval/exercise 
to edit it. 

 Chart up to the last 10 most recent entries (see Charting Intervals and 
Exercises below for more information). 

 Scratch the interval/exercise to display it with a scratch bar on it. This is 
useful if, for a given workout, you did not complete a specific exercise, yet 
you want to keep it in the exercise list. 

 Cut the interval/exercise (for a subsequent paste operation). 
 Copy the interval/exercise (for a subsequent paste operation) 
 Paste an interval/exercise (provided that one has previously been cut or 

copied). 
 Move the interval/exercise up in the list. 
 Move the interval/exercise down in the list. 

Charting Intervals and Exercises 
Interval and exercise charts show up to the last 10 occurrences and allow you to see your 
progression (see Figure 40). Note that those charts are not accessible from the Graph view. 
 
To see such a chart, right-click on an interval or an exercise, and click Chart: 
 

 Intervals are shown with the duration time in red and the recovery time in blue. Actual 
duration is either the total duration (set * time) or the duration itself, depending on your 
Display option setting (see section 8.2 for Display options). 

 
 Exercises are shown using either the weight itself or the total weight (set * rep * weight) 

(see section 8.2 for information about Display options). Note that weight-less exercises 
(e.g., crunches) can only be charted when the total weight option is selected. 
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Figure 40: A workout chart depicting the most recent entries for an exercise. 



VidaOne Diet & Fitness for Windows 7, Vista and XP User’s Guide 52 

7.3. Entering Health Data  
To enter health data, click Home > Health Record to show the Health Record data entry 
window (see Figure 41). 
 

  
Figure 41: The Health Record data entry window. 

 
You can enter information about:  
 

 Your weight. An option allows you to use either American or Metric units (see section 
8.1 for details). Another option lets you see your Body Mass  Index (BMI). You can also 
see a chart of your body weight (see section 4.5 for details). 

 
 Your body fat, percentage. The use of a fat caliper makes it easy to obtain this number. 

 
 Your resting heart rate. Note that it is best to check this when you wake up (i.e., at rest). 

 
 Your blood pressure. An option lets you see an assessment of it (low, normal, elevated 

high, severe). You can take it at any time of the day, although it is preferable to take at 
about the same time from one day to another (e.g., when you wake up, when going to bed 
at night, etc.) 

 
 Your activity level for the day. This allows better calculating your BMR. 
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 Your mood for that day. 
 

 Up to four (4) custom fields. See page 41 for details. 
 
 Sleep quality and duration. 

 
 A note. 

 
 The following body measurements (which can be charted in the Graph view): 

 
o Neck 
o Biceps 
o Forearm 
o Wrist 
o Chest 
o Waist 
o Hip 
o Thigh 
o Calf 
o Ankle 

 
 The following blood markers (which can be charted in the Graph view), and you can add 

you own (see section 10.7 for details): 
 

o Albumin 
o BUN 
o Calcium 
o Chloride 
o Cholesterol 
o Cholesterol (HDL) 
o Cholesterol (LDL) 
o CO2 
o Creatinine 
o Estradiol 
o Globulin 
o Glucose 
o Hematocrit 
o Hemoglobin 
o Insulin 
o Iron 
o Phosphorus 
o Potassium 
o Sodium 
o Triglyceride 
o Uric Acid 
o White Blood Count 
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It is best to enter this information a few days per week to provide accurate graphs. At a 
minimum, you should enter your resting heart rate and weight on a weekly basis, in order to 
review your performance over time. 
 
You can enter multiple health records per day, which is ideal if you need to monitor a condition, 
such as glucose levels.  
 
If you enter multiple weights for a given day (i.e. if you weigh yourself more than once on a 
given day), the last weight (the most recent) will be used for various calculations (such as 
calculating the BMR for the day). 
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7.4. Browsing Intervals, Exercises, Courses, and Locations 
You can browse, add, or delete intervals and exercises when prompted to enter one. For instance, 
Figure 37 on page 46 shows the Exercise window where you can add, edit/view, or delete 
exercises.  
 
When adding a workout, you can add, edit/view, or delete a courses or location by clicking on 

the Update button  and choosing among Add, Edit or Delete.  
 
When adding exercises, you can specify the muscle groups being worked on by either checking 
their name off, or clicking on them in the muscle chart. Later on, when entering exercises (see 
section Entering Strength Training Exercises on page 46), your own exercises will be listed if 
you use the muscle chart to select an exercise. 
 

 
Figure 42: The Add Exercise window. You can specify which muscle groups are being worked on. Later on, 

when adding exercises for a workout, your own exercises will be listed if you use the muscle chart. 
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8. Using Polar or Garmin Heart Rate Monitors 
If you own a supported Polar or Garmin monitor, you can directly download the exercise files 
(the workouts stored in the monitor) into VidaOne Diet & fitness. The models currently 
supported are the following: 
 

(http://www.polarusa.com) 
 

 AXN500, AXN700 
 F6, F11, F55 
 CS200, CS300, CS400, CS600, CS600X 
 RS200, RS400, RS800, RS800CX 
 S410, S510, S520, S610, S610i, S625X, S710, S710i, S720i, S725, S725X, S810, S810i 
 Polar Power Kit (wired or wireless) 

 
(http://www.garmin.com) 

 
 Edge 205, 305 
 Forerunner 205, 301, 305 
 TCX files can also be imported from Edge 605, Edge 705, Forerunner 405CX, etc. 

8.1. Downloading Exercises from a Garmin Monitor via USB Cable 
To download exercises, connect your Garmin device to your computer via a USB cable, click 
Fitness > Download in the Garmin section. The workouts will automatically be downloaded 
and listed (see Figure 43).  Click View to display the route using Google Maps (see Figure 44) 
which requires a live Internet connection. From that screen, you can also export the file into an 
HTML file or a GPX file.  
 
Click Save to store the data into a workout. Exercise files are stored as GPBX files stored under 
My Documents\VidaOne \profile\GPS and can be viewed by editing workouts. Once saved, edit 
the workout and right-click on the exercise file name to review it (see Figure 45). 
 

  
Figure 43: Exercise files from a Garmin device. 
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Figure 44: Viewing an exercise file from a Garmin device. 

 

 
Figure 45: Accessing a Garmin exercise file that was saved in a workout. 

Right-click to view, 
export or email the 
exercise file.
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8.2. Importing Garmin TCX Activity Files 
Some Garmin devices cannot be directly downloaded into VidaOne Diet & Fitness because they 
do not connect via a USB cable. Example of such devices are: Forerunner 310XT, Edge 500, 
Edge 705, etc. These devices can only be downloaded into Garmin Training Center® software. 
 
However, activities (workouts) in the Garmin Training Center® software can be exported as 
TCX files. And starting with VidaOne Diet & Fitness 3.4, TCX files can now be directly 
imported and converted into workouts, with full course information. 

Importing TCX Files 
TCX files can be imported in VidaOne Diet & Fitness via the Fitness menu’s Import TCX Files 
button (see Figure 46). You will be prompted to select a file (and you can select multiple files as 
well), choose an activity, and workout(s) will be created accordingly. TCX are converted into 
GPBX files, which is a proprietary compacted format of storing route data. GPBX files are 
synchronized and can be reviewed with VidaOne’s applications for iPhone. 

Exporting TCX Files 
Workouts can be exported as TCS files as follows: 

 Start Garmin Training Center® software and download data from your Garmin device. 

 Select one activity (workout) from the list in the lower left corner. 

 Choose from the menu File > Export > Export “date” e.g. Export “1/1/2010 2:08:40 PM” 
(see Figure 47) 

 In the Save As window, make sure that “Garmin Training Center Database Files (*.tcx)” 
is selected next to “Save as type:” 

 Note the file name in the Save As window (e.g. “1_1_2010 2_08_40 PM_history.tcx”), 
and click Save. 

 

 
Figure 46: Importing a TCX file into VidaOne Diet & Fitness. 
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Figure 47: Exporting an activity as a TCX file from Garmin Training Center®. 
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8.3. Downloading Exercises from a Polar Monitor 
To download exercises, select the Fitness > Download in the Polar section. The Heart Rate 
Monitor wizard will be shown (see Figure 48) and will guide you step by step through 
downloading the data from your heart rate monitor. The exact procedure depends on the monitor 
(the steps are self explanatory), but common features are the following: 
 

 You can create a new workout based on the heart rate data; 
 

 You can replace an existing workout in VidaOne Diet & Fitness by the data from the 
heart rate monitor; 

 
 You can merge two or more exercise data files (from your heart rate monitor) into one 

workout in VidaOne Diet & Fitness. This is particularly useful if you briefly interrupted 
your workout, resulting in two exercise data files in your heart rate monitor. See section 
8.6 for details.  

 

  
Figure 48: The Heart Rate Monitor download wizard guides you step by step  
through downloading your workout data right into VidaOne Diet & Fitness. 

 
Upon downloading a workout from your heart rate monitor, the data is saved into an .HRM file.  
 

Note 
 

HRM files downloaded by VidaOne Diet & Fitness are by default located  
in the “My Documents\VidaOne\profile\year” folder  

(e.g., My Documents\VidaOne\Jeff\2008).  
You can change the directory via the Options (see section 8.11). 
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Once the data is downloaded, the workout window is displayed, showing the name of the 
exercise file which was downloaded. Right-click on the file name to view it (using VidaOne 
Viewer) or email the file, a very handy feature if you want to quickly send your HRM data to 
your coach or friends. 
 

 
  

Right-click to view 
or email the 
workout data file. 
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8.4. Viewing Exercise Files 
Polar and Garmin exercise files, along the routes recorded with MySportTraining for iPhone, are 
shown via the VidaOne Viewer application (see Figure 49). The exact information that is 
displayed depends on your heart rate monitor model and available options. For instance, the 
Power, Power Index and Power L-R values are available with some Polar® monitors equipped 
with the Polar Power Output Sensor™. Multiple files can be seen at once. 
 
 
 
 

 

 
Figure 49: VidaOne Polar allows you to see one or more heart rate monitor workout data. 

 
VidaOne Viewer displays a chart with several lines, each of them corresponding to one of the 
following parameters: heart rate, speed, cadence, altitude, power, power index and power left-
right balance (power L-R). These parameters are only listed if they were recorded during the 
workout. Each parameter is summarized on the right: it is displayed with the minimum, 
maximum, and average values. The checkbox next to each parameter allows you to show/hide 
the associated line on the chart (if you want to clearly display only one parameter, for example). 
 
You can click-and-hold anywhere on the chart and the values at that point will be displayed 
below for each parameter, allowing you to identify specific values on a chart (such as a high 
altitude point). 
 

Click anywhere 
on the chart and 
the values at that 
point will be 
displayed below 

These options 
allow you to 
customize the 
display. 

Click here to see lap 
data when present. 

Click here to see the time 
spent in the training zones. 
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Note that VidaOne Viewer automatically filters invalid or zero values. Specifically, the 
following values are corrected: 

 
 Heart rate samples that are below 30 or above 250 are ignored. Heart rate monitors are 

very sensitive to electromagnetic signals and may store incorrect values from time to 
time. 

 
 Speed, cadence, power samples that are zero (when you stopped or stopped pedaling) are 

discarded. 
 
There are three ways to view exercise files: 
 

1. In VidaOne Diet & Fitness, edit a workout, right-click the exercise file name and select 
View. Polar files are searched under My Documents\VidaOne \profile\year) or as 
specified in the option (see section 8.11). Garmin files are stored under  
My Documents\VidaOne \profile\GPS. 
 
If the data was downloaded from VidaOne Polar (as HRB files) or VidaOne GPS (as 
GPB files) on a Windows Mobile and later synchronized, the files are searched in the 
same directories, and in the ActiveSync / Windows Mobile Device Center 
synchronization folder, under “MySportTraining”. For example: 
 

On XP: My Documents\Jeff Tilt My Documents\MySportTraining 
On Vista: Documents\Documents on Jeff Tilt\MySportTraining 

 
Routes created using MySportTraining for iPhone are stored as GPBX file, in the same 
GPS directory, and can be viewed as mentioned above. 

 
2. In the Windows File Explorer, double-click an exercise file (or right-click on it and 

choose Open). 
 

3. When the VidaOne Viewer is running, you can drag exercise files from the Windows File 
Explorer directly onto VidaOne Viewer to open them. 

 
When viewing a file, VidaOne Viewer allows you to do the following (the images on the left are 
the corresponding toolbar buttons): 
 

 Print the chart (File | Print). 
 

 Email the HRM file to a friend or coach (Tools | Send to Mail Recipient). This feature 
uses your standard email settings. 

 
 Export the HRM file to a .CSV file, which can be viewed by Microsoft® Excel  

(Tools | Export to CSV File). 
 

 Zoom in and out to see the workout details. 
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 See lap information (if available). Click Tools | Show Laps to display lap information, as 

shown in the figure below. To remove that window, click Tools | Show Laps again. 
 

 
Figure 50: VidaOne Polar can show lap information when available. 

 
 Get data about a specific period of time (snapshot). Click Tools | Select Snapshot to 

enter in the snapshot mode. In that mode, the cursor appears as a cross when positioned 
over the graph and a snapshot window is will be shown (see Figure 51). Press and hold 
the mouse’s left button and drag the mouse to select a period of time. The data for that 
period is displayed in the Snapshot window. To remove the window and exit the snapshot 
mode, click Tools | Select Snapshot once more. 

 

 
Figure 51: That snapshot mode allows you to select a portion  

of your workout and gets statistics about it. 

 
 Display the time spent in each zone (Figure 52). Click Tools | Time in Zones to display a 

window that shows the time spent in each training zone. Click Tools | Time in Zones 
again to remove the window. 

 

 
Figure 52: VidaOne Polar can show the time spent in each training zone. 
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You can also customize the appearance of the charts as follows: 
 

 Select Smooth Curves to smoothen the curves and show the trends.  
 

 Check Show Laps to display laps (shown as purple vertical bars). The option is disabled 
if there is no lap information available. 

 
 Select a different background from among the following choices: 

 
o None, which displays a white background. 
 
o Lines, which displays horizontal lines matching the markers on the Y-axis. 

 
o Training Zones, which paints your heart rate zones, as calculated in VidaOne 

Diet & Fitness (see section 9.4). This option allows you to quickly see the 
intensity of your workout. 

 
Select Options from the Tools menu to change general display options, such as setting a 
different speed or altitude scale, using different line colors, or using thicker lines. 

8.5. Importing Polar HRM Exercise Files 
If you previously downloaded exercise files from your Polar heart rate monitor into HRM data 
files, choose Fitness > Import HRM Exercise Files, and choose a file. A workout will be 
shown, as if you had downloaded the data from your heart rate monitor. Modify the workout 
values if need be, and click OK to create the workout, or click Cancel to abort. 
 
As with a download, VidaOne Diet & Fitness prompts you if a workout took place on the same 
date and time. In that case, you can choose the following: 
 

1. Replace the workout with the new one. 
 
2. Update the existing workout with the HRM data (the distance, pace, and heart rate data 

fields are updated). 
 

3. Attach the HRM data file to the workout, but leave the workout information intact. 
 

4. Cancel the operation (and leave the existing workout intact). 
 
You can also select multiple files when prompted for a file, by clicking on each file while 
pressing the Ctrl key. VidaOne Diet & Fitness will then asks you if you want to use the same 
activity (or not) for each workout, and whether you want to edit each workout before importing 
them. If you are importing various files that are related to the same activity (e.g. “Road 
Cycling”) and you just want to import them “as is”, these options allow you to import them all at 
once automatically. 
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8.6. Converting HRB Files to HRM Files 
If you are using VidaOne Polar for Windows Mobile Pocket PC, Polar workouts are downloaded 
as HRB files on your Pocket PC, and synchronized with your PC. These HRB files contain a 
proprietary format and can be viewed with VidaOne Diet & Fitness HRM (see section 8.1).  
 
To convert these HRB files to standard Polar® HRM files (which can be viewed with Polar 
Precision Software for instance), choose Convert HRB Files, select one or several HRB files, 
specify an output folder, and click Convert. The original HRB files themselves will be left intact, 
and the corresponding HRM files will be created. 

8.7. Merging HRM Data 
VidaOne Diet & Fitness has a unique helpful feature: merging of HRM data. Imagine the 
following scenario: during a bicycling workout, you take a 10-minute break at a convenience 
store to fill yourself up with cold liquids. By the time you’re back to your bike, your heart rate 
monitor, which sits on your bicycle handle bar, has shut down the current exercise. You have no 
choice but to start a second exercise. But what you really want is to get the data for the whole 
workout. 
 
VidaOne Diet & Fitness allows you to reconstruct the original workout from two exercise data 
files and obtain the summary data for the whole workout as if it had not been interrupted. 
Whether you download data from your heart rate monitor or import HRM files, VidaOne Diet & 
Fitness verifies your workouts beforehand, and notifies you if there is a workout – called a back-
to-back workout – that either ended up within one hour or started within one hour of the current 
workout. If this is the case, you can merge the workout with the back-to-back workout, resulting 
in one single workout that combines both. In the scenario presented above, you can merge the 
two workouts into one, and view all the data as if the workout had not been interrupted. 
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8.8. Updating General Settings for Polar S-Series Monitors 
You can update various settings stored in the heart rate monitor via VidaOne Diet & Fitness. To 
do so, select Fitness > Update General Settings. You will then be prompted to select the mode 
of your heart rate monitor, and to establish a connection. Once the connection is established, the 
General Settings window is shown (see Figure 53). There are various categories to choose from: 
 

 User: gender, weight, height.  
 Watch: date and time. 
 Reminders: up to seven (7) reminders can be programmed. 
 Monitor: monitor settings (specific functions). 
 Bicycles: up to two (2) bicycle settings can be entered. 

 
Note that all these parameters are specific to the heart rate monitor and are independent of the 
settings stored in VidaOne Diet & Fitness. 
 

 
Figure 53: The Watch page in the General Settings window. 

Select a category and the 
related fields will be shown 
on the right side. 
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8.9. Updating Exercise Settings for Polar S-Series Monitors 
You can program up to five exercise settings in your heart rate monitor. Choose Fitness > 
Update Exercise Settings,  select your heart rate monitor model and connect, and the exercise 
list will be shown (see Figure 54). There are two types of exercises: continuous  and intervals 

, described in the following paragraphs. 
 

 
Figure 54: The Exercise List window shows the five exercises stored in the monitor. 

 
Continuous exercises are based on up to three timers, which automatically repeat (1-2-3-1-2-3-
etc.) until you stop the workout. You can associate heart rate limits with each timer. For instance, 
Figure 55 shows continuous training using two timers. In this case, the first timer is used as a 15-
minute warm-up. The HRM will beep when the heart rate falls below 132 or goes above 152. 
The warm-up is then followed by a 90-minute work period, during which the HRM will beep 
when the heart rate falls below 152 or goes above 172. Following the workout, the third timer 
kicks in, which has been set for a 15-minute cool-down period (no alarm will beep based on the 
measured heart rate). An optional recovery phase can be set in addition to these periods. This 
type of exercise is ideally suited for working on your aerobic system. 
 

Double-click an exercise to 
edit it. 



VidaOne Diet & Fitness for Windows 7, Vista and XP User’s Guide 69 

 
Figure 55: Continuous training window. 

 
Interval-based exercise consists of 1 or more sets of high-intensity efforts followed by short 
periods of active recovery (rest). This type of exercise is designed to improve your high-end 
endurance. In addition to these sets, interval-based exercises include a warm-up and cool-down 
phases, which can be based on duration, heart rate, or distance (for S710 models only). 
 
Whichever type you choose to define, simply follow the various screens that gather all the 
information required for the exercise. For more details about the exercises and various options, 
refer to your heart rate user’s manual. 

8.10. Polar Connection Settings 
You can configure how the connection is established between your computer and your Polar 
heart rate monitor. Click Fitness > Connection Settings, and then choose the interface (IrDA, 
Polar Interface or Polar SonicLink) and the connection port (serial or USB). 
 
Click the Test button to ensure that the connection parameters are correct and that a connection 
can be established with the heart rate monitor. Note that when testing the connection via 
SonicLink, first select your monitor then click the Test button. 

8.11. Polar Files Location 
You specify the default location of the HRM files by clicking on Fitness > Files Location. You 
can either enter a directory, or click Use Default to use the default directory. 
  

Click this button to quickly 
set the HR limits based on 
your training zones.
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8.12. Garmin Routes on Android, BlackBerry and iPhone 
Workouts recorded with a route using MySportTraining or MyPersonalDiet for Android and 
iPhone are fully synchronized with your PC (as GPBX files) and can be viewed in VidaOne Diet 
& Fitness.  
 
But routes recorded with a Garmin device and downloaded in VidaOne Diet & Fitness are also 
synchronized with your Android and iPhone, and can be viewed in MySportTraining and 
MyPersonalDiet for Android and iPhone as well! 
 

 
Figure 56: Routes recorded on a Garmin device can be viewed in  

MySportTraining and MyPersonalDiet for Android, BlackBerry and iPhone. 
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9. Other Features 

9.1. Choosing a Period 
Report and Graph views are based on a period, which you can change by clicking on it. This will 
display the Period window (see Figure 57), allowing you to choose another period. There are 
several pre-defined periods to choose from, and you can also specify a period by clicking 
Custom period and selecting the start and ending dates. 
 

 
Figure 57: The Period window allows you to choose any period. 
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9.2. Find 
You can search the notes of both workouts and health records for a word via Home > Find. For 
instance, Figure 58 shows the result of finding the word “flat”. You can then click on an entry to 
edit it. 
 

 
Figure 58: The Find window. 
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9.3. Activity Organizer 

Activity Filter 
You can filter activities to show only the activities that are of interest to you, resulting in 
improved clarity. For instance, when adding a workout (as described in the Adding a Workout 
section on page 37), only unfiltered activities will be shown. 
 
To filter activities: 
 

 Click Fitness > Activity Organizer.  The Activity Organizer window is displayed (see 
Figure 59 on page 74). 

 Check activities to be displayed and uncheck those to be filtered. 
 Choose All or Clear to select all or clear all checkboxes, respectively. 
 If desired, click Save as custom filter to record the selected activities as your preferred 

filter. You can then modify the filter, review workouts, and later come back and click 
Custom to restore your own filter. 

 
Note 

 
Filtered activities (those that are not checked) are no longer displayed in the views.  

In order to see them again, you must check them in Filter Activities again. 

Exporting and Importing Food Items 
You export workouts as routines by selecting an entry in the list and clicking Export. Then 
select a file name (with the VDX file extension) and click OK. To import a routine (e.g. from 
your friend), click Import, select a VDX file, and the routine will be stored under My Food. 
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Figure 59: The Activity Organizer window. 
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9.4. Gears 
You can track the gears you use for your workouts, either by distance or duration. This is very 
helpful regarding their maintenance and replacement. For example, you can track the following: 
 

 Running shoes (by distance), to determine when to replace them. 
 

 Bicycle and equipment, such as chain, tires, wheels (by distance), to maintain them as 
needed. 
 

 Heart rate monitors and other electronic devices (by duration), to determine when to 
replace their battery 

 
To view add, edit or delete gear, choose Fitness > Gears (see Figure 60). When editing a 
workout, tap on the Gear button  to enter the gear you used in a workout, and VidaOne Diet & 
Fitness will automatically calculate their usage. You can also add, edit and delete gear when 
entering a workout. 
 

 
Figure 60: The Gears window. 
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9.5. Goal 
VidaOne Diet & Fitness offers you the ability to set and measure a goal.  For instance, say you 
set a goal of exercising 350 hours for this year and you want to know how close to this goal you 
are. Click Fitness > Goal to show the Goal window. First define the goal (which can be either a 
target weight gain, target weight loss, duration or distance) and a period, and then click Update. 
The outcome will be displayed in the bottom half of the window.  
 
Figure 61 illustrates such a goal. The chart displays two lines: the first (pale blue) indicates the 
target achievements whereas that second shows t he actual accomplishments. You can precisely 
visualize where you stand with respect to your goal. 
 

 
Figure 61: The Goal window allows you to set and measure a goal. 
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9.6. Personal Best 
You can see a list of your ‘personal best’ workouts (those are the workouts whose rating is set to 
‘Personal Best’) by choosing Fitness > Personal Best (see Figure 62). You can sort the list by 
tapping on the column headers (Workouts, Time, Calories or Distance). All workouts (regardless 
of their date and the activity filter) whose rating is “Personal Best” are listed. 
 

 
Figure 62: The Personal Best window lists all workouts rated ‘Personal Best’. 
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9.7. Training Zones  
Training zones are essential for heart rate monitoring-based training. VidaOne Diet & Fitness 
automatically calculates your training zones, a feature that is very useful if you use a heart rate 
monitor. 
 

 
Figure 63: The Training Zones window with the effort coloring option on (left) and off (right). 

 
To calculate your training zones: 
 

 Click Fitness > Training Zones to show the Training Zones window (see Figure 63). 
Colors are used if the effort coloring option is on (see section 10.1 for display options). 

 
 Enter your maximum heart rate (if you have measured it). The default is set to 220 minus 

your age2, provided you entered your birth year in the profile. Note that this formula is 
just an estimate, and your actual maximum heart rate may vary by as much as + or - 20. 
This value is dictated by your genes, not your fitness. 

 
 The training zones are automatically calculated and each training zone is defined as a 

range expressed as a percentage (%) of your maximum heart rate (HR). The exact 
calculation is as follows: 

  

                                                 
2 This is the official formula adopted by the American College of Sports Medicine (www.acsm.org). 
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Zone Minimum Maximum Intensity Description 
5 92 100 Exhausting Anaerobic 
4 85 91 Strenuous Lactate threshold training 
3 75 84 Sustained Aerobic 
2 65 74 Moderate Endurance 
1 55 64 Effortless Recovery 

Table 2: Default training zones. 

 
 You can choose to see either the training zone percentages, or the corresponding heart 

rate beats, calculated on your maximum heart rate. 
 
 If your heart rate monitor only allows you to enter your target zone's minimum and 

maximum as multiples of 5, check off the Use 5-beat increments option to round up 
values as multiples of 5. 

 
 Click the Customize button if you prefer to specify your own training zones. You can 

choose the number of training zones (1 to 10), how they are calculated and specify the 
details for each zone (see Figure 64). 

 

 
Figure 64: You can customize the training zones to fit your workouts. 
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9.8.  Calculators 
VidaOne Diet & Fitness provides some popular health calculators: 
 

 Basal Metabolic Rate (BMR), which is the amount of energy your body needs at rest 
for a day, on average. 

 Body Mass Index (BMI), which is a common weight-to-height ration. 
 Lean Body Mass (LBM), which is the amount of your body weight minus the fat. 

 
Choose Profile > Calculators to show the Calculators window (see Figure 65). The values are 
based on your profile, which you can access from that window by clicking on “profile”. 
 
Check off Add the BMR to the Calorie Intake & Expenditure graph in order to add your 
BMR to the calories your burn during your workouts. 
 

 
Figure 65: The Calculators window allows you determine some common measures. 
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9.9. Exporting Data 
You can export workout and health records into a CSV file, which is directly readable by 
Microsoft® Excel®. To export the data, click Home > Export to show the Export window (see 
Figure 66). Choose the file the export to (it must have the CSV extension), the period and the 
type of records (workouts and/or health records) to export, and click Export. 
 

 
Figure 66: The Export window. 
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9.10. Backup and Restore 
VidaOne Diet & Fitness has the ability to backup the workout and health database and restore it 
if needed. We recommend that you make a backup periodically (once a week) as it only takes a 
few seconds. Should the VidaOne Diet & Fitness database become corrupted, VidaOne Diet & 
Fitness allows you to restore it from a previous backup. 

Making a Backup 
Choose Home > Backup to make a backup of your database. This will show the Backup 
window (Figure 67). Enter the directory where the backup database is to reside (click the “…” 
button to select a directory if required). Then click OK. The database (a file called vodfdb.db) 
will be saved to the specified directory. The file name is vodfdb_date.db. 
 

  
Figure 67: The Backup window. 

 
The backup contains the following: 
 

 All meals for all profiles 
 All workouts for all profiles 
 All health records for all profiles 
 All intervals, courses, exercises, and locations for all profiles 
 All profiles 

 
The backup does not contain the following: 
 

 Some personal settings and options. 

Restoring a Backup 
Click Home > Restore to restore data. You will be prompted to select a vodfdb_date.db file 
(saved by a previous backup). Finally, you will be asked to confirm whether you want to restore 
the data or cancel the operation. Upon confirming, the data will be restored. 
 
You can also restore older database files with the MDB extension (e.g. vodfdb_date.mdb). 
 

Click this button to  open a 
window that allows you to 
choose a directory.
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10. Options and Settings 
The various options and setting allow you to personalize and customize VidaOne Diet & Fitness. 
Options and settings are available from the Profile menu.  

 
Figure 68: The Profile ribbon. 

 
Note that since VidaOne Diet & Fitness uses your computer’s regional settings for date and time, 
there is no option to modify their display settings from within VidaOne Diet & Fitness. 

10.1. My Profile  
The profile consists of personal data to enable the calculation of the calories you burn when 
exercising and to establish your initial training zones. 
 

 Enter your personal information: 
 

o Your gender. 
 

o Your weight, either in lbs or kg, based on the measurement unit setting., which 
you can set below. 

 
o Your birth year. 

 
o Your height, either as m/cm or ft/in, based on the measurement unit setting, which 

you can set below. 
 

 Choose Use 1 decimal for body weight to allow using one decimal with your body 
weight (e.g., 135.4 lbs, or 58,3 kg), as opposed to whole numbers (e.g., 135 lbs or 58 kg). 

 
 Choose the default measurement units, either English or Metric, and the energy unit, 

Calories or kJ. You can still choose any unit at any time, and VidaOne Diet & Fitness 
will automatically convert the data as needed.  
 

 Enter your activity level 
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10.2. Android Wi-Fi Synchronization 
VidaOne Diet & Fitness synchronizes with MySportTraining (vidaone.com/mst_android.htm) 
via Wi-Fi, allowing you to use your PC and Android phone/tablet to track your diet, fitness and 
health, and make backups. To synchronize, click Profile > Android. This opens the VidaOne 
NetSync window (Figure 69), which shows your computer address and port (192.168.0.193 and 
25007 respectively in this figure). Enter those values as is (with the dots) in MySportTraining’s 
Synchronization screen (Figure 70) and tap Synchronize. Please refer to Appendix B for more 
information about VidaOne Net Sync. 
 

    
Figure 69: VidaOne NetSync. 

 
Figure 70: Synchronization in MySportTraining for Android. 

Keep this option selected as it significantly speeds up 
subsequent synchronization operations.  To force a 
synchronization from scratch, unselect it. 

Enter the computer address 
with the dots (.) 

Several addresses might be 
listed. You might have to 
try them all to find out 
which works. 
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10.3. BlackBerry Wi-Fi Synchronization 
VidaOne Diet & Fitness synchronizes with MySportTraining (vidaone.com/mst_bb.htm) via Wi-
Fi, allowing you to use your PC and BlackBerry to track your diet, fitness and health, and make 
backups. To synchronize, click Profile > BlackBerry. This opens the VidaOne NetSync window 
(Figure 71), which shows your computer address and port (192.168.0.193 and 25007 respectively 
in this figure). Enter those values as is (with the dots) in MySportTraining’s Synchronization 
screen (Figure 72) and choose Synchronize. Please refer to Appendix B for more information 
about VidaOne Net Sync. 
 

   
Figure 71: VidaOne NetSync. 

 

 
Figure 72: Synchronization in MySportTraining for BlackBerry. 

 

Keep this option selected as it significantly speeds up 
subsequent synchronization operations. To force a 
synchronization from scratch, unselect it. 

Enter the computer address 
with the dots (.) 

Several addresses might be 
listed. You might have to 
try them all to find out 
which works. 
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10.4. iPhone/iPad/iPod Touch Wi-Fi Synchronization 
VidaOne Diet & Fitness can synchronize with MyPersonalDiet (www.vidaone.com/impd.htm) 
and MySportTraining (www.vidaone.com/imst.htm) for iPhone, iPod Touch and iPad via Wi-Fi, 
allowing you to use your PC and iPhone to track your diet, fitness and health, and make backups. 
To synchronize, click Profile > iPhone. This opens the VidaOne NetSync window (Figure 73), 
which shows your computer address and port (192.168.0.193 and 25007 respectively in this 
figure). Enter those values as is (with the dots) in MySportTraining’s Synchronization screen 
(Figure 74) and choose Synchronize. Please refer to Appendix B for more information about 
VidaOne Net Sync. 
 

 
Figure 73: VidaOne NetSync. 

  
Figure 74: Synchronization in MySportTraining for iPhone, iPad and iPod Touch. 

Keep this option selected as it significantly speeds 
up subsequent synchronization operations. To force 
a synchronization from scratch, unselect it. 

Enter the computer address 
with the dots (.) 

Several addresses might be 
listed. You might have to 
try them all to find out 
which works. 

Make sure Wi-Fi is turned ON. 
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Troubleshooting 
 

If the synchronization does not happen, make sure that Wi-Fi is turned ON on your phone,  
and that the address and port are entered correctly. On your PC, you might also have to modify 
your firewall settings to let VidaOne NetSync receive the incoming connections. In most cases, 

Windows will prompt you to let run NetSync the first time you open it; simply accept (your 
system remains fully protected).. 

 
For Mac OS X, PDF documents that describe how to set-up Parallels Desktop® and VMware 
Fusion™  for the synchronization to work are available at www.vidaone.com/vodf_win.htm. 
 

Note 
 

By Apple’s design, iPhone/iPad/iPod Touch keep applications fully isolated from one another. 
Consequently, the data cannot be shared between MyPersonalDiet and MySportTraining on the 

iPhone. For that reason, each application must be synchronized with VidaOne Diet & 
Fitness. 
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10.5. Windows Mobile and Palm OS synchronization 
 
 Choose Use my profile when synchronizing if you are using a Pocket PC and/or Palm 

OS handheld and you want to synchronize your workouts with it. 
 

 Choose Synchronize only the past month(s) of data (Pocket PC only) to limit the 
amount of data that is kept on your Pocket PC. This is a powerful feature to keep all your 
records on your desktop, but only a subset of it on your Pocket PC in order to save 
storage space. This also speeds up the synchronization process since less data need to be 
synchronized. Choose the period of time (in months) which the data is kept for, on the 
Pocket PC. For instance, if you choose 6 months, only the data for the past 6 months will 
be synchronized with the Pocket PC, whereas all the data will remain available on the 
desktop. 
 

Note 
 

Due to the synchronization operations, it is not recommended to enter or edit data in 
MySportTraining and/or MyPersonalDiet on your mobile device when connected to your PC.  

It is best to synchronize your mobile device once you have entered the data. 
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10.6. Nutrients 
 

 Select the nutrients that you want to track. Only those nutrients will be available and 
displayed throughout this application, instead of the full list of nutrients. 
 

 Choose Show percent daily value (%DV) to show the %DV whenever nutrients are 
displayed, in various views, lists, and graphs. 

10.7. Markers 
 

 Select the blood markers that you want to track. Only those markers will be available and 
displayed throughout this application, instead of the full list of markers. 

10.8. Energy Calculation 
 

 You can increase or decrease the energy calculated for your BMR and workouts. For 
instance, if the calculated BMR is too low, you can increase the calculation by 10% by 
entering 10 below. You can also enter a negative value to reduce it if it is too high. 

 
 Choose  Adjust BMR for the time of the day for VidaOne Diet & Fitness to perform 

energy calculation using the current time, instead of for the whole day. For instance, if 
selected, the BMR at noon will be half than if the option was not selected. 

10.9. Meals Options 
 

 Choose Track points with food for points to be displayed along food items and meals. 
You can also enter your daily points target, which you can track in the Day view. 

10.10. Workouts Options 
 

 Select the first day (Saturday, Sunday or Monday) of your training week. All views take 
this first day into account week when displaying workouts. For instance, choosing This 
Week in the Report view results in the list of workouts for the week, starting on the 
specified day. If you are unsure, select Monday (most training plans start on Mondays). 

 
 Select Copy the exercises/intervals of the previous workout when adding a workout 

in order to automatically carry over the most recent  workout sets (intervals or exercises) 
when adding a workout.  

 
 Select Use seconds with workout duration if you want to specify seconds when 

entering workouts' durations.  
 
 Select Use 2 decimals with distance in order to enter precise distances, such as 1.75 mi. 

The default is one decimal (e.g. 1.5 mi). 
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 Select Show activity names activity lists to display activity names next to the workout 

icons on various lists. If this is unchecked, only the icons are shown. 
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10.11. Health Options 
 

 You can select Show Body Mass Index (BMI) next to weight which also shows a small 
icon. That icon is based on your Body Mass  Index, which is calculated based on your 
height and weight: 

 
 

Underweight 
 

Normal 
 

Overweight 
 

Obese 
 

 Select Show blood pressure assessment  to display a warning/information message 
when you enter your blood pressure, as follows (the systolic value is the higher number 
and the diastolic value is the lower number): 
 
Severe Systolic >= 160 or Diastolic >= 100 
High Systolic >= 140 or Diastolic >= 90 
Elevated Systolic >= 120 or Diastolic >= 80 
Normal 90 <= Systolic < 120 AND 60 <= Diastolic < 80 
Low Systolic < 90 or Diastolic < 60 

 
 You can choose to display or not emoticons (“smileys”) for workouts ratings and health 

mood. 

10.12. Theme Options 
 

 Three themes can be chosen from: silver, blue and black. 
 

 
Silver Blue Black 

 

10.13. Charts Options 
 Choose Use enhanced graphics to use a 3D effect when displaying graphs. Note that 

some graphs do not use 3D effects.  
 
 Choose Zoom graphics to narrow the range of the graphs' vertical axis. If this is 

unchecked, the range starts at zero.  
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 Choose Show average when applicable to display a dotted line representing the average 

on column or line graphs that show 2 or more values. 
 

 Choose Show total duration on cardio charts to display the total duration (sets * 
duration) for cardio (interval) charts. If this is unchecked, only the workout duration is 
shown. 

 
 Choose Show total weight on strength charts to display total weight (sets * reps * 

weight) for strength (exercise) charts. If this is unchecked, no total weight is shown. 

10.14. Start-up Image 
 

 Lets you select an image (if any) to show when the application launches. You can select 
the default image or your own. 

10.15. Show All Messages 
 

 Click on this option to make sure all information messages are displayed. 
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11. Troubleshooting 
 
Here are some common issues and how to solve them. 
 
I click a button to open a window and the application freezes until I press Esc. 
 
Reason: when you are using two monitors, and the window is on the second monitor (which is 
off or disconnected). Pressing esc closes the that and makes the application responsive again.  
 
Solution: open VidaOne Diet & Fitness while pressing the left Ctrl key for 2 seconds. This resets 
all windows positions on the main monitor. 
 
Many of my workouts do not show up. 
 
Reason: the activity filter is blocking them.   
 
Solution: choose Fitness > Activity Organizer, click All and OK. This will make all workouts 
visible. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Thank you for using VidaOne Diet & Fitness!  
 
If you want more features, email us at info@vidaone.com. 
 
The VidaOne team 
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Appendix A: VDX File Format 
The VDX files are XML-based. Knowledge of XML is highly preferable to avoid errors. 

Routines 
The following example describes the Routine 1, with the following exercises: 
 

 Push Up with 3 identical sets of 15 reps (no weight) 
 Arm Curl with 3 different sets: 10x85 lb, 10x85 lb, 8x95 lb 

 
Any number of exercises can be listed, each with up to 250 identical sets or up to five different 
sets. 
 
<?xml version="1.0" ?> 
<VidaOne> 
 
    Creator information is optional 
    <Creator Name="VidaOne Diet and Fitness" Version="3.4.0" /> 
 
    <Routine Name="Routine 1" /> Routine name 
 
    <Exercises> 
 
        <Exercise Name="Push Up"> 1st exercise 
            <Sets Count="3">  Sets means identical sets 
                <Reps>15</Reps> Reps for all sets 
            </Sets> 
        </Exercise> 
 
        <Exercise Name="Arm Curl"> 2nd exercise 
            <Set>    Set means that each set is listed 
                <Reps>10</Reps>  
                <Weight>85</Weight>  
            </Set> 
            <Set>    2nd set (10x85) 
                <Reps>10</Reps> 
                <Weight>85</Weight> 
            </Set> 
            <Set>    3rd set (8x95) 
                <Reps>8</Reps> 
                <Weight>95</Weight> 
            </Set> 
            <Unit>lb</Unit>  All weight in lb 
        </Exercise> 
 
   Additional exercises can be listed here 
 
    </Exercises> 
</VidaOne> 
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Food Items 
The following example is the category Cereals with one food item: Post Cocoa Pebbles.  
 
<?xml version="1.0" ?> 
<VidaOne> 
 
    Creator information is optional 
    <Creator Name="VidaOne Diet and Fitness" Version="3.4.0" /> 
 
    <Category Name="Cereals" />  Category name 
 
    <Food> 
 

  First food item 
        <Item Name="POST Cocoa Pebbles"> 
  The serving must include the size, unit and energy. 

Valid units are: g, oz, tsp, tbsp, l, floz, cup, pint 
Energy must be in calories (Cal) or kJ (kj) 

            <Serving Size="30" Unit="g" Cal="110" /> 
            <Nutrients>    

 List of all nutrients. In this example, all nutrients 
 are listed, but those without values can be omitted. 
 The nutrient names must be as shown below.  

                <Carb>26</Carb>  g 
                <Protein>1</Protein> g 
                <Fat>1.5</Fat>  g 
                <SatFat>1</SatFat>  g 
                <MonoFat />   g 
                <PolyFat />   g 
                <Chol />   mg 
                <Phos>20</Phos>  mg 
                <Potas>55</Potas>  mg 
                <Fiber>3</Fiber>  g 
                <Sugar>11</Sugar>  g 
                <Sodium>180</Sodium> mg 
                <Calcium>100</Calcium> mg 
                <Iron>1.8</Iron>  mg 
            </Nutrients> 

The note is optional 
            <Note>1 serving = 3/4 cup (30g)</Note> 
        </Item> 
 
   Additional items can be listed here 
 
    </Food> 
</VidaOne> 
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Appendix B: VidaOne NetSync 
VidaOne NetSync is automatically launched as soon as you log in, provided you’ve run it once 
from VidaOne Diet & Fitness. This allows you to synchronize at any time without opening 
VidaOne Diet & Fitness, provided your computer is on and logged in. 
 
When launched VidaOne appears in your computer toolbar’s tray (in the lower right corner). A 
VidaOne icon is shown either in orange (when connected and synchronizing) or in gray (when 
not connected and waiting). Right-click on it  to show a menu to open VidaOne NetSync, open 
VidaOne Diet & Fitness, remove the icon from the tray permanently or exit VidaOne NetSync. 
 

  
 

Figure 75: Click on VidaOne NetSync in the tray to open it. Right-click on it to display commands. 

Partnerships 
VidaOne NetSync maintains partnerships i.e. synchronization information with each phone it 
synchronizes with. This allows synchronization to be very fast. If you experience 
synchronization issue, unselect Use Existing partnership to force a clean synchronization from 
scratch. 
  

VidaOne Net is always loaded and can 
be accessed via its icon in the tray. 
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Troubleshooting 
If you cannot establish a connection between your phone and VidaOne NetSync, a firewall is 
blocking the connection. That firewall may be on your computer or router. 
 
The first thing to do is to restart your router. It is also recommended to verify with the 
manufacturer if any firmware upgrade is available and apply it. This is especially important on 
older routers. 
 
Also, when you start VidaOne NetSync for the first time on Windows, you will likely see the 
following message: 
 

 
Figure 76: Microsoft Firewall blocking VidaOne NetSync 

 
Make sure to click Unblock to let VidaOne NetSync receives connections, otherwise the 
connection cannot be established. 


